
ASTP for Windows
ASTP allows to retrieve data from CIMEL Electronique instruments with a traditional serial port or a
MODEM. If you experience troubles using ASTPWin, check the minimal required configuration or
send us a bug report.
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BUG Report
If you encounter a software anomaly, send us :

The version of the software (Menu Help->About)●   

The menu name or module name which cause the fault●   

Description : (problem, how to produce the bug, operating system, PC description…)●   

If applicable, the file which causes the fault●   

If it's a software problem, the presumed cause●   

Report all to defossez@cimel.fr or fax-it to CIMEL.

http://www.cimel.fr/
mailto:cimel@cimel.fr
http://www.cimel.fr/
mailto:defossez@cimel.fr


Feel free to write us if you want to improve ASTPWin.

 

Software code and documentation written by Jean-Baptiste DEFOSSEZ
Last changes on 16th June 1999

mailto:defossez@cimel.fr


Minimal required configuration
Operating System Windows 95 or higher, Windows NT 4 Service Pack 3 or higher

Processor
All (A more powerful processor will speed up loading and merging operations
of large files)

Memory 16 Mb (Performances are better with more memory)
Graphical resolution 640*480 16 colors (A lot of screen are best viewed with 65536 colors or better)
Communication port One free COM port

Warning : Version problem with Comctl32.dll file

This problem concern the first version of Windows 95, it doesn't occur on Windows version superior
or equal to OSR B version of Windows 95 (Windows 98 and Windows NT aren't affected). To launch
ASTPWin, you must have on your system the 4.70 version for the Windows DLL COMCTL32.DLL.
Actually with the first version of Windows 95, released in October 95, there's a bug which can hang
up the computer. To install the correct version of this file, you must download the Comctl32.exe file,
available for free on the Microsoft web site and decompress it. Then, restart the computer in DOS
mode and replace the file with the same name (COMCTL32.DLL) which is on the system directory of
Windows (C:\WINDOWS\SYSTEM in most cases). Note that ASTPWin won't run if the version of
this file isn't correct.

http://www.microsoft.com/


Example : PC Transfert for
Sunphotometer CE-318
The data recorded in the memory can be transferred to a PC.

1. Plug the control unit to the PC with the PC-DCP cable. Plug the cable on the RS-232 DCP on the
control unit to a COM1 to COM4 on the back of the PC.

2. Run ASTP Win. In the general setup (  or Tool->General setup menu), setup the
Communication. Select “Serial link”, indicate the COM port you will use and select 1200 bauds for
transfer speed.

3. Connect the COM port (  or Tool->Connect/Disconnect menu). Choose the "PC" scenario
on the command unit and press GO [W] to start the data transfer.

4. At the end, save the K7 file (  or File->Save menu). This process generates a .K7 file, which
contains the true content of the buffer. It’s a binary file.

For special data processing, you can create the text files (  or Measurement->Save ASCII files
menu)



Communication setup

Shortcut : 

Menu : Tools ->General setup, communication tabsheet.

See Also : How to setup the communication

Communication type
Choose the communication type. For a local link with the serial port, choose Serial link, for a
MODEM link, choose MODEM. If you selected MODEM, you can setup the MODEM Initialization
string and the number of ring before picking up.

Automatic connection at the start
This option allows to connect the communication port as soon as ASTP is launched. This option could
be very useful if a power failure occurs and if you want to launch automatically ASTP in reception
mode at the next computer start up.

Port number
It indicates the communication com port name used for the acquisition (from COM1 to COM4).

Speed (bauds)
It indicate the transmission speed used for the acquisition. In local, this option is generally set to 1200
Bauds, with a MODEM, the transmission speed is normally 9600 Bauds.

Stop the connection after two empty events
It’s possible to optimize the reception with that option. The PC will stop the acquisition when it
detects two consecutive empty events (Type 0xFF). When two empty events occur, the rest of the
memory don’t contains any data.



How to setup the communication ?
ASTPWin need to know the link type between the PC and the instrument, the communication port
(from COM1 to COM4) and the transmission speed (1200 or 9600 bauds). To specify your
configuration, select the menu " Tools->General Setup " in the principal menu and click on the
"Communication" sheet.

Link kind choice

For a local link with a serial port, choose Serial link, for a MODEM link, choose MODEM. By
selecting MODEM, you will have to setup the MODEM initialization string, and the number of ring
before the MODEM pick up to answer the call.

Communication port choice

You must indicate the communication port number used for the acquisition (from COM1 to COM4).

Transmission speed

The speed (in bauds) is the speed used for the transmission. That option is generally 1200 Bauds. At
this time, only few instruments (BRDF) can handle 9600 Bauds speed rate. Standard instruments are
running at 1200 bauds.

Communication setup examples

Instrument description Link kind Com port Speed

Polarized sunphotometer on COM1 Serial link COM1 1200

Radiometer connected to the PC on COM2 Serial link COM2 1200

BRDF with a GSM transmitting data to an internal
MODEM installed on COM3

MODEM COM3 9600

BRDF directly connected to the PC on COM2 Serial link COM2 9600

 



Main screen
The screen is composed of different parts. Here’s a screen example, click on the area where you want more
information:

Main menu
File menu

Open a K7 file●   

Save the K7 file●   

Convert K7 files in ASCII files●   

Merge several K7 files●   

Quit●   

Tools menu
Connect or disconnect communication port●   

Show the transmission history●   

Watch and edit parameters●   

Modify the general configuration●   



Measurement menu
Delete measurements●   

Create & save the ASCII files●   

Get more information about a scenario●   

Processing menu
Typically, the ASTPWin plug-ins are installed in that menu●   

Help menu
Read this help file●   

Get information about the software version●   

Shortcuts icons
The shortcuts icons accelerate the access to a particular function. To learn the meaning of the icons pictures, see
“ Icons shortcut meaning  ”. To know the signification of each image, let the mouse cursor a few seconds over it.

Information about the communication
It’s a text zone giving information about received scenarios. It describes also the transmission errors. This part is
only visible if the communication port has been opened.

Transmission status
This little control screen show the transmission progression :

Transmitted memory is an estimation of the memory transmitted by the instrument.

Received characters count the amount of characters received by the communication port.

Time give the time elapsed from the beginning of the transmission.

The Statistics part allows each second to follow the transmission state. The reception LED is on when data are
received, under that led the program compute the transmission speed from it’s start and the graphic show the
number of received characters for the last thirty seconds. This part is only visible if the communication port has
been opened.

K7 file information
It’s an information panel used to show some general information : The complete file name, it’s size size and the
number of scenarios (Data) and the name of the CIMEL instrument. At the bottom of the panel is a list of the
scenarios contained in the K7 file. That list is composed by these columns :

Type Scenario type (short name or extension)●   

Date / Time Time when the scenario starts●   

Size Size of the event in bytes●   

Data Show the digital counts.●   

You can sort that list by your criterion by clicking on the title of the column. Double click on a measurement to
see the details. Note that when a transmission occurs, you're not allowed to modify that list.

If the scenario isn’t recognized by the software, the type is ? ? ?. Please contact CIMEL Electronique to add the



new scenario in the program.



K7 to ASCII files conversion
Menu : File -> Convert in ASCII

You can create ASCII files with a list of K7 files. You can organize the files in periods.

K7 files to convert
Give the list of the files used for the conversion. You can Add or Remove files in that list.

Output directory
Name of the directory where will be stored the ASCII files.

Files period
The text files data could be organized in different ways :

None

Files are created with the same name of the K7 file (MMDDhhmm.EXT).

●   

Hourly

Data are grouped hour by hour. The files are named hhDDMMYYYY.EXT.

●   

Daily

Data are grouped day by day. The files are named DDMMYYYY.EXT.

●   

Monthly

Data are grouped month by month. The files are named MMYYYY.EXT.

●   

Yearly

Data are grouped year by year. The files are named YYYY.EXT.

●   

Infinite

The data are grouped in the same file. The filename is nom de base.

●   

Warning : Bigger is the period, longer is the computation time when adding data.

ASCII files base name
The base name is an optional prefix that ASTP adds before the text file name. E.g. if the base name is
"PARIS_" and you choose a Monthly period, for the month of June 99, the filename will be
PARIS_0698.EXT (EXT is the extension of the ASCII file)



Conversion progress
Used to see the progression of the files conversion.



Merge K7 files
Menu : File->Merge K7 files

With this dialogue box you can merge several K7 files. This action is very useful if you want to gather
some days together to compute it in one operation. It’s also possible to create a K7 file that contains
scenarios of several K7 files. Double and scenarios with errors are eliminated.

K7 source file directory
Indicate where are stored the K7 files used for the fusion. All the files in that directory will be merged
in one big K7 file.

Fusion type
You can add all the scenarios (Complete fusion) or you can eliminate the scenarios which aren’t
between the two dates (Between two dates fusion).

Fusion progress
To see the progression of the K7 files merging.



Transmissions history
Menu : Tools >Transmission history.

ASTPWin can display statistics about the transmission done during the current session. These
statistics are useful for example, if the user isn't physically present during automated transmission.
This dialog is the list of the transmissions done during the current session.

Number of transmissions
Amount of communication from the start of ASTPWin.

Columns description
Date time column

Date and time when the transmission started.

●   

Duration column

Duration of the transmission (in hours, minutes and seconds).

●   

Errors column

Number of errors during each transmission. It’s an indication of the transmission
quality.

●   

End Trans. column

Show how the transmission ended:

OK: It normally ends.❍   

Canceled: The transmission was canceled by the user.❍   

Timeout: There was no data during about 10 seconds. No program has ended the
connection.

❍   

Bad trans: The connection was so bad that the program terminate the transmission.❍   

 

●   

Scenarios column

Amount of scenarios (a line of measurements) transmitted.

●   

Bytes column

Amount of bytes transmitted during the communication.

●   

Speed column●   



Compute a transmission speed (in characters / sec.).

Max speed column

Indicate the maximum speed (in characters / sec.) over five sliding seconds.

●   

Save
Prompt the user to save the list in a ASCII file (text file).



How to suppress bad measurements
inside a K7 file ?
It's possible to suppress bad or uninteresting scenarios.

Select scenarios to remove , click on the right mouse button and select " Remove ". It's also possible
to suppress the events with the main menu " Measurement->Delete measurements ".

The selected scenarios are definitely removed from the K7 file.



Measurement details
Menu : Measurement -> Measurement details

It’s possible to get more details about a particular measurement. You can double click on the scenario
you want to watch to open this dialog box.

A grid appears with the list of the values composing the measurement.

Each symbol correspond to a data type family :

Date of the measurement
Time of the measurement

Filter number

Temperature

System data
Battery voltage
Angle

Physical data (Digital Count)

 



Data processing and Plug-Ins

ASTPWin software organization
ASTPWin is an open software which support particular treatments adding :

How the Plug-Ins system work ?
Physically, a plug-in is a .DLL file with optionally some others data files. When it's placed in the
plug-in directory, it's automatically added in the ASTPWin interface (typically in the " Processing "
menu) when the application starts :



In that example, "Transmitter data decoding" is physically DCPFiles.DLL

Plug-Ins directory
You must indicate in what directory the plug-ins (DLL files) are stored. To modify that directory,
enter the Miscellaneous options setup : select the menu " Tools->General setup " click on the " misc. "
tab and give the full path of the directory in the field " Plug-ins directory ".

If that directory contains valid .DLL files for ASTPWin, the new processing will be added ASTPWin
at its next start (you must restart ASTPWin for changes to take effect).



Miscellaneous setup

Shortcut : 

Menu : Tools->General setup, Misc. sheet.

Display empty scenarios (.INI)
That option allows to force the empty scenarios display in the scenarios list.

Display scenarios with errors
That option allows to force the display of scenarios with errors (Transmission errors, bad integrity
test, unknown scenario or impossible to decode…)

Confirm before overwriting files
By deactivating this option, you remove the confirmation message when the program want to
overwrite an existing file on the disk. You have to deactivate this option when the program is use in
automatic mode (without a user to reply to that question).

Write transmissions report
This option create a file containing a little communications report. Each transmission adds a line to
that file. The filename is Transmission.Log, it’s stored in the ASTP home directory. That file is never
deleted, data are always added to the end of that file. The user should delete periodically this file.

Configuration directory
Indicate the directory where are stored the instrument description files (SP??????.PAR files).

Plug-ins directory
The DLL executable files for ASTPWin are stored in this directory. The correct Plug-ins DLL are
automatically recognized by the software and the process are added to the “Processing” menu. See
also "Data processing and Plug-Ins".



Icons shortcut signification

 Open a K7 file.

 Save the data in a K7 file.

 Connect / Disconnect the communication port. The program is ready to receive a
communication only if that button is down (See also how to launch the acquisition ?)

 Create the ASCII files. The ASCII filenames have the same base name of the current K7 file.

 Launch the general configuration dialog

 Stops the current communication (that icon is available only during a transmission)

 Edit the current K7 parameters



How to launch the acquisition ?
Connect the communication port

To activate the link with the serial port, select the item " Tools->Connect / Disconnect " in the main
menu or click on the following shortcut icon :

Link connection ON / OFF

The acquisition progression visualization should appear :

The software is now waiting for an instrument transmission.

If the dialog don't appear, the communication port can't be opened :

Verify the communication port number.●   

Verify if the communication port isn't already used by Windows or by another application.●   

Some portable computer doesn't have COM1 communication port. Choose another
communication port

●   

Acquisition start

The acquisition start when the instrument begin to send data :

Connect the instrument to the chosen communication port●   

Select the PC scenario on the instrument (see the instrument documentation for much details,
by default : MAN / SEL / PC / GO ).

●   

The data reception LED becomes green as soon as data from the instrument is coming :

This panel gives some information about the status of the current acquisition. The transmitted memory
is the percentage of memory uploaded in the PC. The number of characters received, the amount of
time from the transmission starts and the average acquisition speed in characters per second are given



for information. The graphic shows the last 30 seconds of transmission, it allows to report the stability
and the cuttings during the data transmission.

Acquisition end

The acquisition stops automatically, but can be terminated by a user intervention :

Stop transmission

The data transfer end if one of these conditions is done :

The instrument memory is fully transmitted (Detection : the last received scenario was already
received at the start of the transmission)

●   

Two consecutive empty events were received and the related stop option was activated.●   

The connection between the PC and the instrument was broken (no data received during several
seconds)

●   

The connection between the PC and the instrument is too bad (less than two characters per
seconds transmitted during the 30 last seconds)

●   

The transfer was interrupted by the user●   

Then, the scenarios list is refreshed.



Parameters edition

Shortcut : 

Menu : Tools->Parameters edition

The K7 file contains the data and the instrument parameters.

If the parameters configuration file is available, the program show us the list of the K7 file
parameters. It's also possible to modify these parameters by double clicking on it.

 Save parameters
Save the parameters in a normal text file.

 Print parameters
Print the list of the parameters.

Parameter column
Name of the parameter.

Value column
Value of that parameter.

Description column
Give a description of that parameter.



K7 files management

What's a .K7 file ?
A .K7 file is originally an image of the inquired instrument memory. It's size is 32kb, exactly the size
of the classical CIMEL Electronique instrument memory. The new extensions allow to overtake that
size and the .K7 files produced by ASTPWin can do more than 32kb.

Importance of K7 files in relation to ASCII files
A K7 file can produce ASCII files, but the inverse isn't true. It's very important to keep the K7 file
rather than the ASCII files. The K7 file contains :

Instrument parameters (at the acquisition time)●   

The scenarios that are correctly decoded●   

The bad or partially transmitted scenarios (except for merged files)●   

If a scenario isn't well decoded (due to a software problem for example), it's possible to correct the
bug from the K7 file. If the use remove the K7 file, it's impossible to go back. Besides ASTPWin
plug-ins are exclusively using K7 file format.

ASTP for DOS compatibility
The compatibility between ASTPWin and ASTP for DOS is total and in both directions :

ASTP for DOS can use ASTPWin files.●   

ASTPWin can use ASTP for DOS files.●   

There's a limitation with files larger than 32kb that aren't supported by ASTP for DOS (it occurs for
merged K7 files for example).



ASCII file format setup

Shortcut : 

Menu : Tools -> General setup, ASCII Format sheet.

Display years on four digits
The dates could be displayed with four or two digits (E.G. 2001 or 01), check this option to display
completely the dates, on four digits.

Dates and times between quotes
It’s possible to add quotes (") around the dates and the times. This option could be useful with some
other software to recognize automatically the dates.

Dates and times with not significant zeros
That option allows the display the dates in a fixed length format. To take an example, the 1st January
1998 is displayed 01/01/98 instead of 1/1/98.

Add a description header before each ASCII file
It's possible to add a description header describing each column at the beginning of the ASCII files.
Select the checkbox to add it, here is an example of a file with this kind of header :

Date,Time,1020nm,870P1,670nm,440nm,870P2,870nm,936nm,870P3,Temperature
06/03/1999,13:33:40,56,65,29,1,0,70,2,3,28.7
06/03/1999,13:33:29,57,66,30,1,0,71,2,3,28.7
…

Always display data with numbers
Some information and error codes can be displayed explicitly, for example an absent temperature will
be displayed "Abs.". ASCII exportation will also export "Abs." and may crash some programs that are
waiting for a numerical value. That option force the software to use numerical value : "6513.1" for the
absent temperature to take the same example.

Separators
It’s possible to modify the character of each separator : Select the separator to modify in the list and
assign a character to it.



Selection test
This test line allows to show quickly the effects of the changes done on this page.



Data configuration

Shortcut : 

Menu : Tools-> General setup, Data sheet.

 

It's possible to create automatically after every transfer :

The .K7 file of the acquisition●   

ASCII files organized by period●   

Activate automatic K7 recording
That option activate the automatic K7 files saving. The files are stored in the directory you indicate.
The name of the file is automatically created with the PC date at the instant of the end of the
reception. The filename is MMDDhhmm.K7 (MM = Acquisition month, DD = Acquisition day, hh =
Acquisition time and mm = Acquisition minute). Activate this option allows to setup the ASCII data
files creation.

In directory
Directory where should be stored the K7 files when automatic K7 recording is active.

Create ASCII files
That option confirm the text files creation.

Files period
The text files data could be organized in different ways :

None

Files are created with the same name of the K7 file (MMDDhhmm.EXT).

●   

Hourly

Data are grouped hour by hour. The files are named hhDDMMYYYY.EXT.

●   

Daily

Data are grouped day by day. The files are named DDMMYYYY.EXT.

●   

Monthly

Data are grouped month by month. The files are named MMYYYY.EXT.

●   

Yearly●   



Data are grouped year by year. The files are named YYYY.EXT.

Infinite

The data are grouped in the same file. The filename is base name.

●   

Warning : Bigger is the period, longer is the computation time when adding data.

Base name
The base name is an optional prefix that ASTP adds before the text file name. E.g. if the base name is
"PARIS_" and you choose a Monthly period, for the month of June 99, the filename will be
PARIS_0698.EXT (EXT is the extension of the ASCII file)

Optimize transmissions
That option allows to stop the transmission when the soft detect a scenario already transmitted in one
of the previous transmissions.
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